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APES Tool Step-by-Step Manual 
Version 2.1.2; by Chantal Vögeli

Dear APES User 

This step-by-step manual is designed as an introduction to APES and is mainly aimed 
at beginners using APES for the first time. Advanced APES users may also consider 
recent  publications  using  APES.  For  an  extensive  publication  list,  visit 
http://www.apes-tool.ch/publications.html 

Content: 
Step 1: APES Download/ Installation
Step 2: Create a new scheme
Step 3: Create actor group/ actors
Step 4: Create phase/ events
Step 5: Create relations
Step 6: Edit and weight relations/ Choose stripe color
Step 7: Edit actor relation types
Step 8: Hide/ aggregate data
Step 9: Generate matrices
Step 10: Generate target diagram (actor-actor graph)
Step 11: APES Analysis
Step 12: Export a scheme/ Display several schemes

Step 1: APES Download/ Installation

A. APES Download/ Installation

The APES download is free for non-commercial use. APES can be downloaded from 
the APES webpage (www.apes-tool.ch). 

The APES download is available to users running Linux/Unix/Mac OS X and Windows. 
APES runs on a Java Runtime Environment (JRE), minimum version 1.5. 

Choose either "Download for Windows/OSX users", respectively "Download for Linux 
users"  and  follow  the  instructions  of  the  installation  wizard.
 
If  technical  problems  do  occur  while  installing  or  using  APES,  please  contact 
apes@apes-tool.ch.
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Step 2: Create a new scheme

1. Open APES Tool.
2. Go to “File” -> Choose “new” for creating a new scheme (choose “open” for 

opening other APES-files).
3. Go to “Edit”  -> Choose “Edit  Title” -> Enter title  of  your scheme into the 

corresponding array -> Press “Apply” (see table 2.1).

Table 2.1 Create a new scheme
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Step 3: Create actor group/ actors

A. Create an actor group

1. Go to “Edit” -> Choose “Add a new actor group” -> Enter name of your first 
actor group into the corresponding array -> Press “Add”.

2. For any additional actor group, repeat this procedure as often as necessary.
3. For editing the label or the order of any actor group within the scheme, put 

the cursor on the small box placed left of each actor group label -> Make a 
right-click on your mouse; a window appears -> Within this window, choose 
the option “Edit” and alter your data entry for this particular actor group or 
change the order of the actor group by pressing either “move up” or “move 
down” -> Confirm by pressing “Apply” (see table 3.1).

Table 3.1: Create or edit an actor group
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B. Create actors

1. Go to “Edit” -> Choose “Add new actor” -> Choose first the actor group in 
which the corresponding actor is to be placed -> Enter then the name of the 
new actor into the corresponding array -> Press “Add”.

2. For any additional actor, repeat this procedure as often as necessary. Do not 
forget to always choose the correct actor group in which the corresponding 
actor is to be placed. 

3. For editing the label  or the order of any actor within the scheme, put the 
cursor on the small box placed left of each actor label -> Make a right-click on 
your mouse;  a window appears  -> Within  this  window, choose the option 
“Edit” and alter your data entry for this particular actor or change the order of 
the actor within his actor group by pressing either “move up” or “move down” 
-> Confirm by pressing “Apply” (see table 3.2).

Table 3.2 Create or edit an actor
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Step 4: Create phase/ events

A. Create a phase

1. Go to “Edit” -> Choose “Add a new phase” -> Enter name of your first phase 
into the corresponding array -> Press “Add”.

2. For any additional phase, repeat this procedure as often as necessary.
3. For editing the label or the order of any phase, put the cursor on the small 

box placed below each phase label -> Make a right-click on your mouse; a 
window appears -> Within this  window, choose “Edit”  and alter  your data 
entry for this particular phase or change the order of the phase by pressing 
either “move left” or “move right” -> Confirm by pressing “Apply” (see table 
4.1).

Table 4.1 Create or edit a phase
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B. Create events

1. Go to “Edit” -> Choose “Add a new event” -> Choose first the phase in which 
the corresponding event takes place -> Enter then the name of the new event 
into the corresponding array -> Press “Add”.

2. Set then the date for this new event by pressing “Set the date”; a calendar 
window opens -> Choose the correct date on which this event took place -> 
Enter once again the year in which this event took place in the first array (as 
default the value 0 is being set) -> Press “Apply”.

3. For any additional event, repeat this procedure as often as necessary. Do not 
forget to always choose the correct phase in which the corresponding event  
took place.

4. For editing the label or the order of any event within a phase, put the cursor 
on the small box placed above each event label -> Make a right-click on your 
mouse; a window appears -> Within this window, choose the option “Edit” 
and alter your data entry for this particular event or change the order of this 
event by pressing either “move up” or “move down” -> Confirm by pressing 
“Apply” (see table 4.2).

Table 4.2 Create or edit events
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Step 5: Create relations

1. Go to “Edit” -> Choose “Add a new relation” -> Choose the actor that is to be 
related  to  an  event  -> Choose the  corresponding  event  -> Set  a  relation 
attribute,  if  applicable  (by default  all  relations  are  set  as  “active”;  choose 
“passive” for a passive participation, or “leading” for a leading function of this 
particular  actor  for  this  particular  event;  see  Step  6  of  this  manual  for  
information on how to edit the labels) -> If applicable, enter a tool tip info 
into the corresponding array -> Press “Add” (see table 5.1).

2. For  any  additional  relation,  repeat  this  procedure  as  often  as  necessary 
(Relations  can  also  be  added  by  simply  double-clicking  directly  into  the 
scheme). 

3. For changing relations per event, move your cursor to the participation symbol 
you want to alter (node or triangle) -> Make a right-click on your mouse; a 
window  appears  ->  Within  this  window,  choose  the  option  “Change 
participation” -> By clicking this option, the chosen participation symbol alters 
automatically  between  dark-  or  light-coloured  node  (active  or  passive 
participation) and triangle (leading participation). Click this option repeatedly 
until your preferred participation symbol appears.

4. For deleting a relation, move your cursor to the participation symbol you want to 
delete (node or triangle) -> Make a right-click on your mouse; a window appears 
-> Within this window, choose the option “Delete”.

Table 5.1 Create relations
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Step 6: Edit and weight relations/ Choose stripe color

By  default,  APES  proposes  three  labels  for  relations  within  a  scheme  (“active”, 
“passive”, and “leading”). These labels correspond with a certain weighting value per 
label  (leading=3;  active=2;  passive=1),  which  is  then reflected  in  the generated 
matrix per scheme (but not in the visualized scheme itself). Both the labels and the 
weighting value per label can be edited however. To do so, follow the instructions 
below (see table 6.1):

1. Go to “File” -> Choose “Preferences” -> A window showing both relation type 
descriptions and relation values opens.

2. For editing labels or weighting values, just click with your cursor into the 
corresponding array and enter your text and figures.

3. If only one participation type is needed, tick the corresponding box. All 
symbols within the scheme will then be displayed as dark colored dots (symbol 
for active participation). 

4. Within this feature, the color of the stripes of the scheme can be chosen. To 
do so, click on the “Choose”-button, and select your preferred stripe color. -> 
Press “Apply”. 

Table 6.1 Edit and weight relations/ Choose stripe color
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Step 7: Edit actor relation types

By default, APES suggests a symmetric interaction between all actors participating in 
the same event which is  represented by a symmetric  actor-actor matrix.  Since a 
symmetric interaction does not always correspond to empirical findings though, APES 
provides additional actor relation types. The user can therefore choose between a 
symmetric relation (by default), or asymmetric sender relations (“cycle” or “chain”).1 

In order to edit actor relation types, follow the instructions below:

1. Move your cursor to the small box above the particular event for which you 
want to edit the actor relation type -> Make a right-click on your mouse; a 
window  appears  ->  Within  this  window,  choose  the  option  “Edit  actor 
relation”; a window showing relations between all participating actors for this 
particular  event appears (by default,  all  relations  are symmetric;  see table 
7.1).

Table 7.1 Symmetric actor relation type (by default)

 

2. In order to change the actor relation type given by default,  choose either the 
“Cycle”- or the “Chain”-actor relation type. A “Cycle”-actor relation type suggests 
a  circular  participation  type,  which  defines  no  starting,  and no  ending  point. 
However the participation of the involved actors is not reciprocal, but directional 
(see table 7.2).  

1 In the current version, APES only provides a symmetric actor-actor matrix. The asymmetric actor-actor matrix, representing 
the edited actor relation types mentioned above, will be available with the next version of APES, though. 
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Table 7.2 Asymmetric actor relation types (Cycle)

3. In contrary, a “Chain”-actor relation type suggests a linear participation type, 
which defines a starting, and an ending point. The participation of the involved 
actors is therefore again not reciprocal, but directional (see table 7.3).  

Table 7.3 Asymmetric actor relation types (Chain)
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4. Within both the “Cycle”- and the “Chain”-actor relation types, the user can edit 
singular relations. In order to do so, move your cursor on the arrow-symbol of 
the actor relation you want to edit -> Click the arrow-symbol you want to edit 
repeatedly,  until  your  preferred  arrow-symbol  appears.  Choose  the  double 
arrow for a symmetric relation (<->), the arrow pointing to the right-hand side 
for an asymmetric sender relation (->), or the arrow pointing to the left-hand 
side for an asymmetric receiver relation (<-).

5. APES also provides two typical actor relation types stemming from Social Network 
Analysis. A relation can either be designed as “sending star” or “receiving star”, 
which is a variation of both, the “Cycle”- and the “Chain”-actor relation types. In 
order to do so, make a right-click on the actors boxes within this window -> a 
second window opens, in which you can either choose to move a certain actor up 
or down the actors list, or choose the “sending star”- or “receiving star”-actor 
relation. By doing so, the arrows will alter accordingly (see table 7.4).  

Table 7.4 Edit actor relation types 
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Step 8: Hide/ aggregate data

A. Hide data

1. Event names can be hidden. In order to do so, make a right-click on your 
mouse;  a  window appears  ->Within  this  window,  choose the option  “Hide 
event names”.

2. Hidden  event  names  can  be  reset.  To  do  so,  make  a  right-click  on  your 
mouse; a window appears -> Within this window, choose the option “Show 
event names”.

3. All  items  within  the  scheme can  be  hidden  (actor  groups,  actors,  phases, 
events). To do so, choose the items to be hidden by ticking the boxes above, 
below or left of the corresponding item -> Make a right-click on your mouse; a 
window appears  -> Within  this  window,  choose  the  option  “Hide  selected 
items”.

4. Hidden items can be reset. To do so, make a right-click on your mouse; a 
window appears  ->  Within  this  window,  choose  the  option  “Show hidden 
items”.

B. Aggregate data

All  data within the scheme can be aggregated.  APES suggests three aggregation 
types: 

a) Actor group with event (aggregation type I)
b) Phase with actor (aggregation type II)
c) Actor group with phase (aggregation type III; combination of I and II)

All three aggregation types are performed along two distinct dimensions: 

 Quantitative participation (sum of all relations; visualized by the size of the 
nodes in the scheme)

 Qualitative participation (sum of active/ leading relations; visualized by the 
brightness of the nodes in the scheme)

For each aggregation type all actually existing relations are counted. Whereas the 
highest sum per actor group or per phase is set as key reference of 100%, all other 
actor groups or phases are being assessed in relation to this key reference. 

For the quantitative participation all assessed data is filed within a five-scale interval, 
visualized by five distinct node sizes. The largest node stands for the highest scale, 
i.e. 100% (see Table 8.1 below).
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Table 8.1 Five-scale interval for quantitative participation
Node Size Interval

Interval 1

     Interval 2

Interval 3

Interval 4

Interval 5

As  for  the  qualitative  participation all  assessed data  is  filed  within  a  three-scale 
interval,  visualized  by  three  distinctive  degrees  of  brightness.  The  darkest  node 
stands for the highest scale, i.e. 100% (see Table 8.2).

Table 8.2 Three-scale interval for qualitative participation
Brightness of Node Interval

 Interval 1

      Interval 2

      Interval 3

Whereas aggregation types I and II are performed independently from one another, 
aggregation type III is a combination of I and II. Therefore, all aggregated nodes 
within aggregation type III are to be understood as an intersection of aggregation 
types I and II. Each key reference in aggregation type III is therefore assessed in 
relation to aggregation types I and II. 

Please note, that all  aggregations are always performed in relation to all  actually 
existing  relations  within  the  scheme,  including  the  ones  that  are  not  being 
aggregated. Therefore, if you edit any relation within the scheme, be aware, that 
aggregated nodes may most probably alter as well. 
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In order to perform all aggregation types, follow the instructions below:

a) Actor group with event (aggregation type I)

1. Tick the box left of the actor groups you want to be aggregated (see table 
8.3).

2. Make a right-click on your mouse; a window appears -> Within this window, 
choose the option “Aggregate selected items” (see table 8.4 below).

3. If  you  wish  to  reset  the  aggregation  feature,  make  a  right-click  on  your 
mouse; a window appears -> Within this window, choose the option “Reset 
Graph” -> Deactivate the ticked boxes left of the actor groups by ticking them 
again.

Table 8.3 Selected actor groups to be aggregated
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Table 8.4 Aggregated scheme (aggregation type I)

b) Phase with actor (aggregation type II)

1. Tick the box below the phases you want to be aggregated (see table 8.5 
below)

2. Make a right-click on your mouse; a window appears -> Within this window, 
choose the option “Aggregate selected items” (see table 8.6 below).

3. If  you  wish  to  reset  the  aggregation  feature,  make  a  right-click  on  your 
mouse; a window appears -> Within this window, choose the option “Reset 
Graph”  -> Deactivate  the  ticked  boxes  below the  phases  by  ticking  them 
again.
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Table 8.5 Selected phases to be aggregated

Table 8.6 Aggregated scheme (aggregation type II)
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c) Actor group with phase (aggregation type III)

1. Tick the box left of the actor groups and below the phases you want to be 
aggregated (see table 8.7).

2. Make a right-click on your mouse; a window appears -> Within this window, 
choose the option “Aggregate selected items” (see table 8.8 below).

3. If  you  wish  to  reset  the  aggregation  feature,  make  a  right-click  on  your 
mouse; a window appears -> Within this window, choose the option “Reset 
Graph” -> Deactivate the ticked boxes left of the actor groups, respectively 
below the phases by ticking them again.

Table 8.7 Selected actor groups and phases to be aggregated
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Table 8.8 Aggregated scheme (aggregation type III)

Step 9: Generate matrices

In  its  current  version,  APES generates  matrices  that  can be  exported  into  other 
software packages such as Ucinet (Borgatti et al. 2002) and others. Two types of 
matrices can be generated: 

a) actor-event matrix
b) actor-actor matrix 

In order to generate an actor-event matrix go to “Matrices” and choose “Actor-event 
matrix”.  APES then generates a matrix for each actor per event. The values of the 
matrix correspond with the participation types. If the participation types are being 
weighted, the corresponding value is being displayed within the matrix (the example 
below shows weighted values, 1 corresponds to a passive participation, 2 stands for 
an active, and 3 for a leading participation; see table 9.1 below). 
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Table 9.1 Actor-event matrix

The actor-actor matrix, which is also to be found under "Matrices", aggregates the 
values edited for the actor-event matrix. Within this feature, you can either choose a 
standard matrix ("Standard values"), counting the value 1 in case of a relation and 0 
in case of no relation, or choose a weighted matrix ("Participation type sum values") 
that includes the weighted participation types by simply summing them up. With the 
weighted matrix, the visualization of the actor's position within the network is being 
more  pronounced,  but  does  not  generate  different  results  however.  If  an  actor 
gathers a lot of relations with other actors, he will be placed in the centre of the 
network  regardless  of  which  matrix,  the  standard  or  the  weighted  one  is  being 
applied (see table 9.2).

Table 9.2 Actor-actor matrix (standard values)

The  generated  matrices  can  easily  be  exported  into  Excel  or  other  displaying 
programs:
Press the “Copy to clipboard”-button on the matrix tables. All  information is then 
copied. -> Open Excel (or other displaying programs) -> Make a right-click on your 
mouse and choose the option “paste”. All data will then be imported into this new 
table. 
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Step 10: Generate target diagram (actor-actor graph)

In its current version, APES provides a network feature that displays an actor-actor 
matrix as so-called target diagram. With this graph, the nodes are being arranged 
according to their centrality values2 on concentric circles with increasing radii. For 
this procedure, nodes are placed on the radii based on their distance from the center 
of the diagram. For each node, the distance to the center is computed in proportion 
to its centrality score. Like this, an increasing distance to the center of the target 
diagram reflects a decreasing centrality. 
Since it is not the goal of our application to implement a complete catalogue of Social 
Network  Analysis  (SNA)  features  -  which  already  exist  within  other  software 
packages - we decided to provide only one type of centrality measure for plotting the 
target diagram. We therefore chose Bonacich's (1972) eigenvector centrality.
The basic assumption with Bonacich's computation of eigenvector centrality is that 
the  centrality  for  a  specific  node  is  not  to  be  considered  as  isolated  from  the 
centralities  of all  other nodes in the network.  A node that is  connected to other 
central  nodes  experiences  an  additional  enhancement  of  its  own  centrality  and 
generates a centrality augmentation for all other nodes that are connected to it as 
well. In this context, Bonacich developed a set of so-called local (focused on only one 
node) and global (with a broader focus on several nodes) centrality measures which 
are weighted according to his basic assumption. With the introduction of a weighting 
parameter into his formula, Bonacich suggests the insertion of a positive or negative 
value which stands pro or contra the allowance of path distances between nodes. If 
path distances are being considered - as APES does -, not only directly, but also 
indirectly linked nodes are integrated into the centrality computation. 

In order to generate a target diagram with APES3, 

1. Display the scheme you want to plot as target diagram within the actor-event 
(edit) modus.

2. Go to “Mode” and choose “Actor-Actor” -> The target diagram for this scheme 
is being plotted (see table 10.1 below).

3. For editing the target diagram, make a right-click on your mouse; a window 
appears -> By default, APES chooses the maximum and minimum eigenvector 
centrality  value (in percent)  for  plotting the radii  of  the diagram. You can 
however edit these maximum- and minimum-values by directly writing into the 
corresponding arrays (see table 10.2 below). 

4. If  you do not want to display the actor labels or the connecting lines, i.e. 
arrows, click on the corresponding boxes so that the tick marks disappear.  

5. The labels within the diagram can be moved around. To do so, click with the 
cursor of your mouse on the label that you want to move. -> Keep the mouse 
clicked,  while  moving the  label  to  the preferred  position  within  the  target 
diagram. 

2 In Social Network Analysis (SNA), centrality values can be computed for each node. There exist several centralities that all 
express a slightly different alignment (for a well founded overview see Wasserman/Faust 1994; Scott 2000). The most popular 
centrality values are the ones conceptualized by Freeman (1979; degree, closeness and betweenness centrality), as well as 
Bonacich's (1972) eigenvector centrality.
3 In its current version, APES uses the standard actor-actor matrix for plotting the target diagram. In a next version however, it 
will be possible to choose the matrix (standard or weighted), on which the target diagram is to be plotted. 
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Table 10.1 Actor-actor target diagram

Table 10.2 Editing feature for actor-actor target diagram

2



APES Tool manual/ version 2.1.2
__________________________________________________________________________________________

Step 11: APES Analysis

In its current version, APES provides four analytical features, i.e. indicators. These 
are: 

a) actor participation
b) phase duration
c) actor per phase participation
d) actor-actor centralities (eigenvector centrality)

a)  The  actor  participation  analysis computes  the  ‘total  participation  per 
actor’ (absolute and relative figures), as well as the ‘total participation per actor 
per participation type’ (absolute and relative figures) for the whole process. 

In order to run the actor participation analysis, go to “Analysis” and choose “Actor 
participation” (see table 11.1).
 

Table 11.1 Actor participation analysis
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b) The phase duration analysis computes the ‘total duration of all distinct phases of 
the process’ in absolute (counted in days, from the first to the last date of each 
phase) and relative figures.

 
In order to run the phase duration analysis, go to “Analysis” and choose “Phase 
duration”. 

c) The actor per phase participation analysis computes the ‘total actor participation 
type per each phase and actor group’ (absolute and relative figures). 

In order to run the actor per phase participation analysis, go to “Analysis” and 
choose “Actor/phase participation”. 

d) The actor-actor centralities (eigenvector centrality) are the values that are 
     being computed for the plotting of the target diagram (relative figures). With this
     feature, all values are being displayed in one separate table. 

In order to run the actor-actor centralities analysis, go to “Analysis” and choose 
“Actor-actor centralities”. 
Please  take  note  that  for  generating  the  actor-actor  centralities,  first  the  
corresponding actor-actor graph (target diagram; see Step 10 of this manual) has  
to be plotted.

The generated analysis tables can easily be exported into Excel or other displaying 
programs:
Press the “Copy to clipboard”-button on the analysis tables. All information is then 
copied. -> Open Excel (or other displaying programs) -> Make a right-click on your 
mouse and choose the option “paste”. All data will then be imported into this new 
table. 

Step 12: Export a scheme/ Display several schemes

A. Export a scheme 

APES offers several file formats for exporting a scheme/ target diagram. 

a) Save as xml-file: Go to “File” -> Choose the option “Save as xml” -> Enter correct 
path (keep the suggested suffix (.apes), if you wish to reopen the file with APES).

b) For  all  other  formats:  Go to  “File”  -> Choose  the  option  “Export  actor-event 
graph” (for saving APES scheme) or “Export actor-actor graph” (for saving APES 
target diagram); a window opens -> Choose the preferred file format and enter 
the correct path.
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We  do  not  recommend  any  file  format  in  particular;  however,  the  most 
intuitive ones are pdf, jpg, png, bmp or gif (especially when working with MS 
Office/ Word). 
From  a  graphical  point  of  view,  eps-  (Encapsulated  PostScript)  and  svg-
formats (Scalable Vector Graphics) are of a very high quality. For editing both 
formats, additional image editors like Adobe Illustrator, Inkscape4, Gimp5, or 
others are needed, though.

B. Display/ close several schemes

Within APES several schemes can be displayed at the same time; the application 
then generates a header for each scheme. For switching from one scheme to the 
other, just click on the corresponding header. 

For closing one particular scheme, display the scheme you want to close -> Go to 
“File” -> Choose “Close”; the selected scheme will be closed by the application.
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4 Download Inkscape for free:  http://www.inkscape.org
5 Download GIMP for free:  http://www.gimp.org
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